This is the documentation for Cloudera Manager 5.1.0.
Documentation for other versions is available at Cloudera Documentation.

Configuring the CDH Version for a Cluster

Required Role:

Cloudera Manager has version-specific features based on the minor and patch versions. For example, Sqoop 2 and the Hive HiveServer2 and WebHCat roles are only available for CDH 4.2.0 or above. These behaviors are controlled by what is configured in Cloudera Manager, not what is actually installed on the hosts. The versions should be in sync, and is the case if parcels are used.

In package-based clusters, you can manually upgrade CDH packages. For example, you can upgrade the packages from CDH 4.1.0 to CDH 4.2.1. However, Cloudera Manager cannot detect this change and behaves as if the cluster is 4.1.0. For example, it will not display Sqoop 2 as a service.

To inform Cloudera Manager of the CDH version change, select ClusterName > Configure CDH Version. In the dialog, Cloudera Manager displays the installed CDH version, and asks for confirmation to configure itself with the new version. The dialog will also detect if a major upgrade was done, and direct you to use the major upgrade flow documented in Upgrading from CDH 4 Packages to CDH 5 Packages.